Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Jakro

new mops aren't working

Recommended Posts

This forum is supported by the 12ozProphet Shop, so go buy a shirt and help support!
This forum is brought to you by the 12ozProphet Shop.
This forum is brought to you by the 12oz Shop.

the problem isn't just that it doesn't drip it's that they are very streaky and barely any ink comes out unless i take out the pump regulator and squeeze it really hard

 

you can't really tell in the video but the lines are completely see-through

Share this post


Link to post
Share on other sites

I'm sorry but I felt uncomfortable watching you try to write.

You should let it soak first. If its too dry you just destroy your tip.

Share this post


Link to post
Share on other sites
hmmm. try turning the mop upside down and squeezing it... maybe that will help.. what kind of mop is it/

 

yea i did that in the vid but i deleted it. oink 1.5 oz streamline mop

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...