Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
seeking

ok, this is the last flash question i will ask for the weekend.

Recommended Posts

heres the deal...

 

 

i have an action on my page that is always moving anytime the page is loaded. because of that, its givng me an assload of problems trying to make the rest of the flash stuff work around the fact that its always moving. it doesnt matter if you understand that or not. what i need to know is, is there a way to make an action, that just repeats indefinitly, but is not effected by any of the other flash stuff? like can i somehow group off the action associated with that one thing, so that if i have a 'go to frame 26' or something, that it does not effect that constantly moving motion. like i had it on a different channel or something. make sense? i cant figure it out and i spent literally 3 hours tonight trying to find a way... someone has to know... help me out, i'll love you forever... im sure its somethign simple, i just dont know really how to use flash...

Share this post


Link to post
Share on other sites

come on, theres gotta be a simple way to do this... i just need to make an action go on indefinitly, regardless of which frame the thing is in...

Share this post


Link to post
Share on other sites

actually, i think i kno wut ur talking about

u want an animation to run no matter what the scripting tells any of ur other crap to do, correct?

if it is, you want to make the animation into a movie clip, i havent used flash in about a year(graff took over) so im kinda rusty.

 

go to insert-new symbol. then choose movie clip from the options in the pop up box. copy and paste all of the frames of ur animation into the movie clip's frames.

when you play back ur movie, u will not be able to see the animation, just the first frame. when u publish ur movie it will sho up in all of its moving glory

hurra!

hope that helped

Share this post


Link to post
Share on other sites
Guest imported_El Mamerro

I think what this guy says should work. Just make sure that after you make that animation into its own movie clip, you put it on the timeline on its own layer, and on the first keyframe you want it to appear. Then add blank frames (NOT keyframes) all the way to the end of the timeline on the movie's layer. That should leave your animation alone while the rest of your page trods along.

 

Oh, and by the way, I was really confused when you referred to it as an "action", since this usually means a script. Just call it an animation thingie and it should be fine. Beer,

 

El Mamerro

Share this post


Link to post
Share on other sites

i copied the frames ionto a new symbol, but the symbol does not show up in my movie. is this normal?

 

you gotta understand, you gotta talk to me like im a 5 year old, cause i have no idea how to do things the right way in flash. i make everything as one long scene. with buttons and shit, i make it so when yo roll over them, it advances to a further scene. so for instance if i have 3 buttons, the first will advance you to scene 50, where the button then does its thing. if you roll off the button, it takes you back to scene one. button two takes you to scene 60, roll off go back to 1, etc. i doubt this is the way its supposed to be, but somehow it works. so my point is, you gotta give me specific directions, dont expect me to know anything, cause i probably dont. im a moron. haha. i dont know the difference between a button, a movie clip and a graphic. i dont know the difference between a keyframe and a frame. although i do know tht you have to place keyframes to change a motion or something. i know about motion tweening. basically, i can fade. thats all i knowhow to do. which is fine, its all i want.

 

what i want to do, exactly, is i have my background image, laying over top of one part is another image. idealy, the second image is to fade in and out, giving the effect of 'glowing'. thats all it has to do. sit there and glow forever.

 

i apologise for being such a fucking pain in the ass about this, but im just hoping someone will find it in their heart to help me out... beer.

Share this post


Link to post
Share on other sites

how do i get a symbol into a layer? like, i know normaly if i want to bring an image into a layer, i just click import, but i cant import a symbol that is already made. or i mean, i dont know how to do it... god, im gonna smash my head against the wall....

Share this post


Link to post
Share on other sites

You talking about getting a symbol that is already made in another flash movie to a new layer in a new movie?? If so why cant you just open both of the movies in the same window and drag your symbol from the old library to your new layer? works for me.. ?

even if that works your assload of problems is because your working in one long sequence and your buttons are triggering some frames that are stopping your animation altogether.. sorry man but you might have to redo that animation by changing your long sequence into movie clips.

Share this post


Link to post
Share on other sites

ok, i have no problem re doing it as movie clips, i just dont know how. if you can give me a basic description of the process, i can learn it, but as i said, i have no clue how to do things right....

 

come on mammero. if you can get me through this, i'll buy you a 6 pack of beer. no lie.

Share this post


Link to post
Share on other sites

If I understand correctly, what qwertyuiop and El Mamerro is right. To have an animation continue to play (or loop) independantly of the timeline you need to make it a movie clip. To do this simply copy all the frames of the animation, create new symbol (movie clip), then create a new layer in the timeline of the movie. From there simply drag the symbil from your library to the correct layer. If the movie clip hasnt been created, then create a new symbol (movie clip) and in symbol edit mode create the movie clip. Once thats done go back to your movie and, as before, create a new layer and drag the symbol from the library.

 

For flash help go to: http://www.flashkit.com

 

They also have a fresh forum at: http://board.flashkit.com/board/index.php

Share this post


Link to post
Share on other sites

THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!! thanks everyone for your help. i know how frustrating it is trying to walk someone through soemthing as difficult to explain as this... but it paid off.... it now works just fine. atleast the one thing does, now i need to see if i can make the buttons work....

Share this post


Link to post
Share on other sites

Register for a 12ozProphet forum account or sign in to comment

You need to be a forum member in order to comment. Forum accounts are separate from shop accounts.

Create an account

Register to become a 12ozProphet forum member.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×